# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d)[1-9](?!\d)/0$0/gm;t' <<< "m/d/yyyy 1,21,3,42,5,63,7,84,9"