using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)[1-9](?!\d)";
string substitution = @"0$0";
string input = @"m/d/yyyy 1,21,3,42,5,63,7,84,9";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}