re = /(?<!\d)[1-9](?!\d)/m
str = 'm/d/yyyy 1,21,3,42,5,63,7,84,9'
subst = '0$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result