$re = '/(?<!\d)[1-9](?!\d)/m';
$str = 'm/d/yyyy 1,21,3,42,5,63,7,84,9';
$subst = "0$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;