import re
regex = re.compile(r"(?<!\d)[1-9](?!\d)", flags=re.MULTILINE)
test_str = "m/d/yyyy 1,21,3,42,5,63,7,84,9"
subst = "0$0"
result = regex.sub(subst, test_str)
if result:
print(result)