#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\d)[1-9](?!\d)"
Local $sString = "m/d/yyyy 1,21,3,42,5,63,7,84,9"
Local $sSubst = "0$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)