import Foundation
let pattern = #"(?<!\d)[1-9](?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"m/d/yyyy 1,21,3,42,5,63,7,84,9"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)