#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\{\"Атрибуты\"\:\")([^"]+)(?:\"\},\{\"Атрибуты\"\:\")([^"]+)\"\}(?:,|)"
Local $sString = "" & @CRLF & _
"{"Атрибуты":"Разъем"},{"Атрибуты":"Lightning / Micro USB / Type-C"}," & @CRLF & _
"{"Атрибуты":"Тип разъема"},{"Атрибуты":"Универсальный"}," & @CRLF & _
"{"Атрибуты":"Сила тока, А"},{"Атрибуты":"3 А"}," & @CRLF & _
"{"Атрибуты":"Поддержка быстрой зарядки"},{"Атрибуты":"Да"}," & @CRLF & _
"{"Атрибуты":"Емкость батареи, мАч"},{"Атрибуты":"10000 мАч"}," & @CRLF & _
"{"Атрибуты":"Производитель"},{"Атрибуты":"EXPERTS"}]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"На выходе в цикле" & @CRLF & _
"|$1---$2" & @CRLF & _
"" & @CRLF & _
"Получится вот так:" & @CRLF & _
"Вид аксессуара---Внешние аккумуляторы | Разъем---Lightning / Micro USB / Type-C|Тип разъема---Универсальный|Сила тока, А---3 А и т.д" & @CRLF & _
"Но нужно больше вводных данных." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")