use strict;
my $str = '
{"Атрибуты":"Разъем"},{"Атрибуты":"Lightning / Micro USB / Type-C"},
{"Атрибуты":"Тип разъема"},{"Атрибуты":"Универсальный"},
{"Атрибуты":"Сила тока, А"},{"Атрибуты":"3 А"},
{"Атрибуты":"Поддержка быстрой зарядки"},{"Атрибуты":"Да"},
{"Атрибуты":"Емкость батареи, мАч"},{"Атрибуты":"10000 мАч"},
{"Атрибуты":"Производитель"},{"Атрибуты":"EXPERTS"}]
На выходе в цикле
|$1---$2
Получится вот так:
Вид аксессуара---Внешние аккумуляторы | Разъем---Lightning / Micro USB / Type-C|Тип разъема---Универсальный|Сила тока, А---3 А и т.д
Но нужно больше вводных данных.
';
my $regex = qr/(?:\{\"Атрибуты\"\:\")([^"]+)(?:\"\},\{\"Атрибуты\"\:\")([^"]+)\"\}(?:,|)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}