// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:\{\"Атрибуты\"\:\")([^"]+)(?:\"\},\{\"Атрибуты\"\:\")([^"]+)\"\}(?:,|)"#).unwrap();
let string = "
{\"Атрибуты\":\"Разъем\"},{\"Атрибуты\":\"Lightning / Micro USB / Type-C\"},
{\"Атрибуты\":\"Тип разъема\"},{\"Атрибуты\":\"Универсальный\"},
{\"Атрибуты\":\"Сила тока, А\"},{\"Атрибуты\":\"3 А\"},
{\"Атрибуты\":\"Поддержка быстрой зарядки\"},{\"Атрибуты\":\"Да\"},
{\"Атрибуты\":\"Емкость батареи, мАч\"},{\"Атрибуты\":\"10000 мАч\"},
{\"Атрибуты\":\"Производитель\"},{\"Атрибуты\":\"EXPERTS\"}]
На выходе в цикле
|$1---$2
Получится вот так:
Вид аксессуара---Внешние аккумуляторы | Разъем---Lightning / Micro USB / Type-C|Тип разъема---Универсальный|Сила тока, А---3 А и т.д
Но нужно больше вводных данных.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}