# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\{\"Атрибуты\"\:\")([^\"]+)(?:\"\},\{\"Атрибуты\"\:\")([^\"]+)\"\}(?:,|)"
test_str = ("\n"
"{\"Атрибуты\":\"Разъем\"},{\"Атрибуты\":\"Lightning / Micro USB / Type-C\"},\n"
"{\"Атрибуты\":\"Тип разъема\"},{\"Атрибуты\":\"Универсальный\"},\n"
"{\"Атрибуты\":\"Сила тока, А\"},{\"Атрибуты\":\"3 А\"},\n"
"{\"Атрибуты\":\"Поддержка быстрой зарядки\"},{\"Атрибуты\":\"Да\"},\n"
"{\"Атрибуты\":\"Емкость батареи, мАч\"},{\"Атрибуты\":\"10000 мАч\"},\n"
"{\"Атрибуты\":\"Производитель\"},{\"Атрибуты\":\"EXPERTS\"}]\n\n\n\n"
"На выходе в цикле\n"
"|$1---$2\n\n"
"Получится вот так:\n"
"Вид аксессуара---Внешние аккумуляторы | Разъем---Lightning / Micro USB / Type-C|Тип разъема---Универсальный|Сила тока, А---3 А и т.д\n"
"Но нужно больше вводных данных.\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.