using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\{\""Атрибуты\""\:\"")([^""]+)(?:\""\},\{\""Атрибуты\""\:\"")([^""]+)\""\}(?:,|)";
string input = @"
{""Атрибуты"":""Разъем""},{""Атрибуты"":""Lightning / Micro USB / Type-C""},
{""Атрибуты"":""Тип разъема""},{""Атрибуты"":""Универсальный""},
{""Атрибуты"":""Сила тока, А""},{""Атрибуты"":""3 А""},
{""Атрибуты"":""Поддержка быстрой зарядки""},{""Атрибуты"":""Да""},
{""Атрибуты"":""Емкость батареи, мАч""},{""Атрибуты"":""10000 мАч""},
{""Атрибуты"":""Производитель""},{""Атрибуты"":""EXPERTS""}]
На выходе в цикле
|$1---$2
Получится вот так:
Вид аксессуара---Внешние аккумуляторы | Разъем---Lightning / Micro USB / Type-C|Тип разъема---Универсальный|Сила тока, А---3 А и т.д
Но нужно больше вводных данных.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}