const regex = /(?:\{\"Атрибуты\"\:\")([^"]+)(?:\"\},\{\"Атрибуты\"\:\")([^"]+)\"\}(?:,|)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\{\\"Атрибуты\\"\\:\\")([^"]+)(?:\\"\\},\\{\\"Атрибуты\\"\\:\\")([^"]+)\\"\\}(?:,|)', 'gm')
const str = `
{"Атрибуты":"Разъем"},{"Атрибуты":"Lightning / Micro USB / Type-C"},
{"Атрибуты":"Тип разъема"},{"Атрибуты":"Универсальный"},
{"Атрибуты":"Сила тока, А"},{"Атрибуты":"3 А"},
{"Атрибуты":"Поддержка быстрой зарядки"},{"Атрибуты":"Да"},
{"Атрибуты":"Емкость батареи, мАч"},{"Атрибуты":"10000 мАч"},
{"Атрибуты":"Производитель"},{"Атрибуты":"EXPERTS"}]
На выходе в цикле
|\$1---\$2
Получится вот так:
Вид аксессуара---Внешние аккумуляторы | Разъем---Lightning / Micro USB / Type-C|Тип разъема---Универсальный|Сила тока, А---3 А и т.д
Но нужно больше вводных данных.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}