re = /(?:\{\"Атрибуты\"\:\")([^"]+)(?:\"\},\{\"Атрибуты\"\:\")([^"]+)\"\}(?:,|)/m
str = '
{"Атрибуты":"Разъем"},{"Атрибуты":"Lightning / Micro USB / Type-C"},
{"Атрибуты":"Тип разъема"},{"Атрибуты":"Универсальный"},
{"Атрибуты":"Сила тока, А"},{"Атрибуты":"3 А"},
{"Атрибуты":"Поддержка быстрой зарядки"},{"Атрибуты":"Да"},
{"Атрибуты":"Емкость батареи, мАч"},{"Атрибуты":"10000 мАч"},
{"Атрибуты":"Производитель"},{"Атрибуты":"EXPERTS"}]
На выходе в цикле
|$1---$2
Получится вот так:
Вид аксессуара---Внешние аккумуляторы | Разъем---Lightning / Micro USB / Type-C|Тип разъема---Универсальный|Сила тока, А---3 А и т.д
Но нужно больше вводных данных.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end