# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-zA-Z])-\n([a-zA-Z])/\1\2/gm;t' <<< "halfword-
secondhalfword
----
word
-
_________________"