re = /([a-zA-Z])-\n([a-zA-Z])/m
str = 'halfword-
secondhalfword
----
word
-
_________________'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result