$re = '/([a-zA-Z])-\n([a-zA-Z])/m';
$str = 'halfword-
secondhalfword
----
word
-
_________________';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;