import re
regex = re.compile(r"([a-zA-Z])-\n([a-zA-Z])", flags=re.MULTILINE)
test_str = ("halfword-\n"
"secondhalfword\n\n"
"----\n"
"word\n\n"
" -\n\n"
"_________________")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)