#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([a-zA-Z])-\n([a-zA-Z])"
Local $sString = "halfword-" & @CRLF & _
"secondhalfword" & @CRLF & _
"" & @CRLF & _
"----" & @CRLF & _
"word" & @CRLF & _
"" & @CRLF & _
" -" & @CRLF & _
"" & @CRLF & _
"_________________"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)