const regex = /([a-zA-Z])-\n([a-zA-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z])-\\n([a-zA-Z])', 'gm')
const str = `halfword-
secondhalfword
----
word
-
_________________`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);