using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\Qcustom_\E.+\d\Q.pid\E";
string input = @"custom_component1.pid
custom_Component2.pid
custom_component300.pid
custom_Newcomponent4.pid";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}