import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\Qcustom_\\E.+\\d\\Q.pid\\E";
final String string = "custom_component1.pid\n"
+ "custom_Component2.pid\n"
+ "custom_component300.pid\n"
+ "custom_Newcomponent4.pid";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}