// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\Qcustom_\E.+\d\Q.pid\E").unwrap();
let string = "custom_component1.pid
custom_Component2.pid
custom_component300.pid
custom_Newcomponent4.pid";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}