package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\Qcustom_\E.+\d\Q.pid\E`)
var str = `custom_component1.pid
custom_Component2.pid
custom_component300.pid
custom_Newcomponent4.pid`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}