re = /^\Qcustom_\E.+\d\Q.pid\E/m
str = 'custom_component1.pid
custom_Component2.pid
custom_component300.pid
custom_Newcomponent4.pid'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end