const regex = /^\Qcustom_\E.+\d\Q.pid\E/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\Qcustom_\\E.+\\d\\Q.pid\\E', 'gm')
const str = `custom_component1.pid
custom_Component2.pid
custom_component300.pid
custom_Newcomponent4.pid`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}