use strict;
my $str = 'custom_component1.pid
custom_Component2.pid
custom_component300.pid
custom_Newcomponent4.pid';
my $regex = qr/^\Qcustom_\E.+\d\Q.pid\E/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}