using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![.\d])\d+(?:\.\d+)+(?![.\d])";
string input = @"1.3.164.1.2583.15.46
546.598.856.1.68.268.695.5955565
x.yz1.3.164a.1
.1.3.164.1
1.3.164.1.
1.3.164..1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}