import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![.\\d])\\d+(?:\\.\\d+)+(?![.\\d])";
final String string = "1.3.164.1.2583.15.46\n"
+ "546.598.856.1.68.268.695.5955565\n"
+ "x.yz1.3.164a.1\n"
+ ".1.3.164.1\n"
+ "1.3.164.1.\n"
+ "1.3.164..1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}