const regex = /(?<![.\d])\d+(?:\.\d+)+(?![.\d])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![.\\d])\\d+(?:\\.\\d+)+(?![.\\d])', 'gm')
const str = `1.3.164.1.2583.15.46
546.598.856.1.68.268.695.5955565
x.yz1.3.164a.1
.1.3.164.1
1.3.164.1.
1.3.164..1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}