$re = '/(?<![.\d])\d+(?:\.\d+)+(?![.\d])/m';
$str = '1.3.164.1.2583.15.46
546.598.856.1.68.268.695.5955565
x.yz1.3.164a.1
.1.3.164.1
1.3.164.1.
1.3.164..1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);