re = /(?<![.\d])\d+(?:\.\d+)+(?![.\d])/m
str = '1.3.164.1.2583.15.46
546.598.856.1.68.268.695.5955565
x.yz1.3.164a.1
.1.3.164.1
1.3.164.1.
1.3.164..1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end