use strict;
my $str = '1.3.164.1.2583.15.46
546.598.856.1.68.268.695.5955565
x.yz1.3.164a.1
.1.3.164.1
1.3.164.1.
1.3.164..1
';
my $regex = qr/(?<![.\d])\d+(?:\.\d+)+(?![.\d])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}