import re
regex = re.compile(r"(?<![.\d])\d+(?:\.\d+)+(?![.\d])", flags=re.MULTILINE)
test_str = ("1.3.164.1.2583.15.46\n"
"546.598.856.1.68.268.695.5955565\n"
"x.yz1.3.164a.1\n"
".1.3.164.1\n"
"1.3.164.1.\n"
"1.3.164..1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")