import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0?[1-9]|1[0 12]):([0-5]\\d)\\s?((?:A|P)\\.?M\\.?)";
final String string = "12:40 pm\n"
+ "1:25 A.M.\n"
+ "05:44p.m\n"
+ "19:55AM.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}