import re
regex = re.compile(r"(0?[1-9]|1[0 12]):([0-5]\d)\s?((?:A|P)\.?M\.?)", flags=re.IGNORECASE)
test_str = ("12:40 pm\n"
"1:25 A.M.\n"
"05:44p.m\n"
"19:55AM.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")