$re = '/(0?[1-9]|1[0 12]):([0-5]\d)\s?((?:A|P)\.?M\.?)/i';
$str = '12:40 pm
1:25 A.M.
05:44p.m
19:55AM.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);