// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(0?[1-9]|1[0 12]):([0-5]\d)\s?((?:A|P)\.?M\.?)").unwrap();
let string = "12:40 pm
1:25 A.M.
05:44p.m
19:55AM.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}