const regex = /(0?[1-9]|1[0 12]):([0-5]\d)\s?((?:A|P)\.?M\.?)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0?[1-9]|1[0 12]):([0-5]\\d)\\s?((?:A|P)\\.?M\\.?)', 'ig')
const str = `12:40 pm
1:25 A.M.
05:44p.m
19:55AM.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}