#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^linux-.*-5\.0\.0-38(-generic)?$"
Local $sString = "linux-image-unsigned-5.0.0-38-generic" & @CRLF & _
"linux-image-5.0.0-38-generic" & @CRLF & _
"linux-headers-5.0.0-38-generic" & @CRLF & _
"linux-modules-extra-5.0.0-38-generic" & @CRLF & _
"linux-modules-5.0.0-38-generic" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")