using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^linux-.*-5\.0\.0-38(-generic)?$";
string input = @"linux-image-unsigned-5.0.0-38-generic
linux-image-5.0.0-38-generic
linux-headers-5.0.0-38-generic
linux-modules-extra-5.0.0-38-generic
linux-modules-5.0.0-38-generic
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}