import Foundation
let pattern = #"^linux-.*-5\.0\.0-38(-generic)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
linux-image-unsigned-5.0.0-38-generic
linux-image-5.0.0-38-generic
linux-headers-5.0.0-38-generic
linux-modules-extra-5.0.0-38-generic
linux-modules-5.0.0-38-generic
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)