re = /^linux-.*-5\.0\.0-38(-generic)?$/m
str = 'linux-image-unsigned-5.0.0-38-generic
linux-image-5.0.0-38-generic
linux-headers-5.0.0-38-generic
linux-modules-extra-5.0.0-38-generic
linux-modules-5.0.0-38-generic
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end