use strict;
my $str = 'linux-image-unsigned-5.0.0-38-generic
linux-image-5.0.0-38-generic
linux-headers-5.0.0-38-generic
linux-modules-extra-5.0.0-38-generic
linux-modules-5.0.0-38-generic
';
my $regex = qr/^linux-.*-5\.0\.0-38(-generic)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}