import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^linux-.*-5\\.0\\.0-38(-generic)?$";
final String string = "linux-image-unsigned-5.0.0-38-generic\n"
+ "linux-image-5.0.0-38-generic\n"
+ "linux-headers-5.0.0-38-generic\n"
+ "linux-modules-extra-5.0.0-38-generic\n"
+ "linux-modules-5.0.0-38-generic\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}