using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$([^$]*)\$([^$]*)\$([^$]*)\$";
string substitution = @"John${1}left${2}Bill${3}right";
string input = @"$ goes $, and $ goes $.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}