// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\$([^$]*)\$([^$]*)\$([^$]*)\$").unwrap();
let string = "$ goes $, and $ goes $.";
let substitution = "John${1}left${2}Bill${3}right";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}