$re = '`\$([^$]*)\$([^$]*)\$([^$]*)\$`m';
$str = '$ goes $, and $ goes $.';
$subst = "John${1}left${2}Bill${3}right";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;