import re
regex = re.compile(r"\$([^$]*)\$([^$]*)\$([^$]*)\$", flags=re.MULTILINE)
test_str = "$ goes $, and $ goes $."
subst = "John${1}left${2}Bill${3}right"
result = regex.sub(subst, test_str)
if result:
print(result)