const regex = new RegExp('\\$([^$]*)\\$([^$]*)\\$([^$]*)\\$', 'gm')
const str = `\$ goes \$, and \$ goes \$.`;
const subst = `John${1}left${2}Bill${3}right`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);